Si están utilizando el image resizer de PHP en ubuntu parece que por default si instalas a mano php5 no trae las librerias GD. Fácilmente corregimos este error instalando lo faltante.

sudo apt-get install php5-gd